const regex = /(?<=Name\s?\:(\s+)?)[A-z]+(?=(\s+)?Date)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Name\\s?\\:(\\s+)?)[A-z]+(?=(\\s+)?Date)', 'gm')
const str = `Name:James Date : 09/04/22
Name : Mary Date : 09/04/22
Name : Tom Date : 09/04/22
Address : America Date : 09/04/22
Address : United Kingdom Date : 09/04/22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}