using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z0-9_-]+@mycompany\.com";
string input = @"user@mycompany.com
user@anothercompany.com
user-123@mycompany.com
first-last@mycompany.com
first_last@mycompany.com
user22!@mycompany.com
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}