#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^SUMME \/ W;\d{1,3};;\d{1,3};\d{1,3};\d{1,3};\K\d{1,3}"
Local $sString = "02.03.;38;;;3;1;42;" & @CRLF & _
"03.03.;36;;;3;;39;" & @CRLF & _
"04.03.;51;;14;9;1;75;" & @CRLF & _
"05.03.;70;;9;9;;88;" & @CRLF & _
"06.03.;26;;;2;;28;" & @CRLF & _
"SUMME / W;221;;23;26;2;272;" & @CRLF & _
"09.03.;35;;10;6;1;52;" & @CRLF & _
"10.03.;50;;3;4;;57;" & @CRLF & _
"11.03.;48;;4;8;;60;" & @CRLF & _
"12.03.;35;;;4;1;40;" & @CRLF & _
"13.03.;15;;;3;;18;" & @CRLF & _
"SUMME / W;183;;17;25;2;227;" & @CRLF & _
"16.03.;23;;7;2;1;33;" & @CRLF & _
"17.03.;36;;1;3;;40;" & @CRLF & _
"18.03.;36;;;8;;44;" & @CRLF & _
"19.03.;34;;;2;;36;" & @CRLF & _
"20.+21.03.;22;;4;3;;29;" & @CRLF & _
"SUMME / W;151;;12;18;1;182;" & @CRLF & _
"23.03.;38;;4;4;1;47;" & @CRLF & _
"24.03.;26;;4;5;;35;" & @CRLF & _
"25.03.;24;;7;5;;36;" & @CRLF & _
"26.03.;22;;;3;;25;" & @CRLF & _
"27.+28.03.;4;;;2;;6;" & @CRLF & _
"SUMME / W;114;;15;19;1;149;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")