const regex = /([^,]+)=(.+?)(?:(?=,[^,]+=)|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^,]+)=(.+?)(?:(?=,[^,]+=)|$)', 'gm')
const str = `arg1 = value1 ,arg2 = value2 ,arg3=uuu,
arg1 = value1 ,arg2 = value2 , arg3=uuu,
arg1 = value,1 ,arg2 = value2 , arg3=u,uuarg1 = ,value,1 ,arg2 = value2 , arg3=u,uu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}