$re = '/^\d{3}$/m';
$str = '000
111
123
321
3211
32
32a
a32
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);