#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((([0-9]{1,2})|(1[0-9]{2,2})|(2[0-4][0-9])|(25[0-5])|\*)\.){3}(([0-9]{1,2})|(1[0-9]{2,2})|(2[0-4][0-9])|(25[0-5])|\*)$"
Local $sString = "192.192.192.192" & @CRLF & _
"192.*.23.34" & @CRLF & _
"*.192.23.*" & @CRLF & _
"192.0.*.0" & @CRLF & _
"192.*.*.*" & @CRLF & _
"192.*" & @CRLF & _
"192.0.*" & @CRLF & _
"192.*.2" & @CRLF & _
"*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")