re = /^((([0-9]{1,2})|(1[0-9]{2,2})|(2[0-4][0-9])|(25[0-5])|\*)\.){3}(([0-9]{1,2})|(1[0-9]{2,2})|(2[0-4][0-9])|(25[0-5])|\*)$/m
str = '192.192.192.192
192.*.23.34
*.192.23.*
192.0.*.0
192.*.*.*
192.*
192.0.*
192.*.2
*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end