use strict;
my $str = '0,00
00,00
000,00
0.000,00
0,01 -- true
0,10 -- true
1,00 -- true
10,00 -- true
100,00 - true
1.000,00 -- true
10.000,00 -- true
100.000,00 --true
1.000.000,00 -- true
10.000.000,00 -- true
100.000.000,00 -- true
1.000.000.000,00 -- true
0,00
00,00
000,00
0000,00
0,01 -- true
0,10 -- true
1,00 -- true
10,00 -- true
100,00 - true
1000,00 -- true
10000,00 -- true
100000,00 --true
1000000,00 -- true
10000000,00 -- true
100000000,00 -- true
1000000000,00 -- true';
my $regex = qr/^(?!^(0{1,3}\.?)+(,00)?$)(\d{1,3}\.?)+(,\d\d?)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}