# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!^(0{1,3}\.?)+(,00)?$)(\d{1,3}\.?)+(,\d\d?)?"
test_str = ("0,00\n"
"00,00\n"
"000,00\n"
"0.000,00\n"
"0,01 -- true\n"
"0,10 -- true\n"
"1,00 -- true\n"
"10,00 -- true\n"
"100,00 - true\n"
"1.000,00 -- true\n"
"10.000,00 -- true\n"
"100.000,00 --true\n"
"1.000.000,00 -- true\n"
"10.000.000,00 -- true\n"
"100.000.000,00 -- true\n"
"1.000.000.000,00 -- true\n\n"
"0,00\n"
"00,00\n"
"000,00\n"
"0000,00\n"
"0,01 -- true\n"
"0,10 -- true\n"
"1,00 -- true\n"
"10,00 -- true\n"
"100,00 - true\n"
"1000,00 -- true\n"
"10000,00 -- true\n"
"100000,00 --true\n"
"1000000,00 -- true\n"
"10000000,00 -- true\n"
"100000000,00 -- true\n"
"1000000000,00 -- true")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.