import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((.*)\\).*?\\(?\\1\\)?";
final String string = "Chiaro Gallo (blabla) (blabla)\n"
+ "Ricard Michaeln ()\n"
+ "Marco Liu (Hong Kong Stock Co Ltd) Hong Kong Stock Co Ltd\n"
+ "Rafiq (Kkska Traning Co (p) Ltd) Kkska Traning Co (p) Ltd\n";
final String subst = "(\\1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}