const regex = new RegExp('\\((.*)\\).*?\\(?\\1\\)?', 'gm')
const str = `Chiaro Gallo (blabla) (blabla)
Ricard Michaeln ()
Marco Liu (Hong Kong Stock Co Ltd) Hong Kong Stock Co Ltd
Rafiq (Kkska Traning Co (p) Ltd) Kkska Traning Co (p) Ltd
`;
const subst = `(\1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);