const regex = new RegExp('(?<!\\d)-?\\d+(?:\\.\\d+)?|\\D', 'gm')
const str = `-99+44+2+-3/3.2-6
31+2--3*43.8/1%(1*2)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}