$re = '@(?<!\d)-?\d+(?:\.\d+)?|\D@m';
$str = '-99+44+2+-3/3.2-6
31+2--3*43.8/1%(1*2)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);