const regex = /([exibebanner [^])(]*)id=["'][^"']+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([exibebanner [^])(]*)id=["\'][^"\']+', 'gm')
const str = `[exibebanner id="300"] <br/>é simplesmente uma simulação de texto da indústria tipográfica <br/><b>[exibebanner id="40"]</b> e de impressos, e vem sendo utilizado desde o século XVI, quando um impressor desconhecido pegou um<br/> <b>[exibebanner id="90"]</b>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}