$re = '/(?<!melt_eng_custom).dict.yaml/m';
$str = '123.dict.yaml
melt_eng_custom.dict.yaml
df.dict.yaml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);