$re = '/((?:^RAP [\d.\d]+ .+){1}(?:\n^[a-zA-Z0-9].+)+)/m';
$str = '
Modelo Educativo Centrado en el Aprendizaje con Enfoque por Competencias Plan 2008 Página 5 de 20
Carrera: TÉCNICO EN PROGRAMACIÓN Unidad de Aprendizaje: BASES DE DATOS
RED DE COMPETENCIAS (GENERAL Y PARTICULARES)
Competencia particular 2
Utiliza gestores y lenguajes de
bases de datos para la gestión y
manipulación de la información de
las bases datos.
Competencia particular 3
Aplica protección a las bases de
datos para su confidencialidad,
disponibilidad e integridad.
Competencia General
Desarrolla bases de datos normalizadas e implementando políticas de seguridad con gestores
de bases de datos para la explotación de la información a través de lenguajes consulta a base
de datos.
RAP 2.2 Utilizan lenguajes de acceso a
bases de datos para la manipulación de
la información contenida en las Bases
de Datos.
RAP 2.1 Utiliza gestores de bases de
datos para la administración de las
bases de datos.
RAP 3.2 Aplica transacciones para
asegurar la autenticidad de la
información para asegurar su
confiabilidad.
RAP 3.1 Aplica protección al acceso de
los datos para mantener su privacidad.
Competencia particular 1
Diseña Bases de Datos
normalizadas aplicando el
modelado de datos Entidad-
Relación y Relacional para genera
el esquema conceptual y lógico.
RAP 1.1 Contextualiza los conceptos
fundamentales de Bases de Datos.
RAP 1.2 Contextualiza los diferentes
Modelos de datos utilizados para el
diseño de Bases de Datos.
RAP 1.3 Modela bases de datos
normalizadas aplicando las
metodologías de desarrollo del
esquema conceptual y lógico.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);