import re
regex = re.compile(r"((25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(25[0-4]|2[0-4][0-9]|1[0-9][0-9]|[0-9]?[1-9])", flags=re.MULTILINE)
test_str = ("192.168.1.1\n"
"8.8.8.8\n"
"9.9.9.9\n"
"127.0.0.1\n"
"255.255.255.255 # can't end in 255, reserved for broadcast\n"
"0.0.0.0 # can't end in 0, i don't know what that's reserved for\n"
"0.0.0.1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")