package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w)+o`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit
asdfasdf asdoasdf asdf aso o`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}