$re = '/(\w)+o/';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit
asdfasdf asdoasdf asdf aso o';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);