$re = '/\b\p{N}+\s+(?:an|year|سنة)s?/m';
$str = '"I\'m 24 years old" "J\'ai 25 ans" "I have 25 year" "عندي ٢٣ سنة "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);