Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(^| |[a-z-A-Z]{2,}|[a-df-zA-Z]| *-[0-9]+|[0-9]+)(-)([0-9]+|[0-9]+e[0-9]+|[0-9]+-e[0-9]+)
/
gm
Input 1
1
New
-1 1-1 1e1 1e-1 -1e-1 1e-1-1e-1 -1e-1-1e-1 last-1 last-1e-1-1e-1 1+1 -1-1