import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "rr\\d---sn-[a-z0-9]{8}-\\w{4}\\.googlevideo\\.com";
final String string = "rr9--- - -abcd.googlevideo.com\n\n"
+ "rr1---sn-8xgn5uxa-quhl.googlevideo.com\n"
+ "rr1---sn-8xgn5uxa-quhl.googlevideo.com\n"
+ "rr3---sn-8xgn5uxa-quhz.googlevideo.com\n"
+ "rr6---sn-8xgn5uxa-quhl.googlevideo.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}