package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4}-\d{2}-\d{2})(T\d{2}:\d{2}:\d{2}(\.\d{3})?(Z|[+-]\d{2}:\d{2})?)?$`)
var str = `1995-12-05
2023-01-10T19:00:12
2023-01-10T20:59:59+00:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}