package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[r🇷]\s*[🇪e]\s*[p🇵]\s*[🇴o]\s*[🇸s]\s*[t🇹]`)
var str = `repost
r 🇪 p O s t
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}