using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/\/\/.*)?facebook\.com(?:\/[^ ""]*)?";
string input = @" <a href=""www.https://www.facebook.com/xcvxdfddfd/dsfdsf/dsfdsf"" title=""xxx na facebooku"" target=""_blank""><i class=""fab fa-facebook-square fa-lg"" aria-hidden=""true""></i>xxx</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}