#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(faturou\s|faturamento de\s|faturei\s|de um faturamento )*(mais\sde\s)*(((((R\$)+(\s)*(\d){1,6}(\s)*((\.|\,)*\d{1,3}|k|mil)*)))+|((de\s(\d){1,3}(k|mil)\spara\s(\d){1,3}(k|mil)))+)(\sde\sfaturamento)*(\sem\s(menos\sde\s)*(\d{1,2})\sdias)*(\sfoi o que a minha (aluna|cliente|mentoranda|mentorada)+ faturou)*(\sapós o curso)*"
Local $sString = "(já\s)*(como\s)*(em\sum\s[u|ú]nico\sdia\s(minha\smentoreanda\s)*" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"mentorada faturou" & @CRLF & _
"Foram mais de R$50.000 após o curso" & @CRLF & _
"mentora que já faturou mais de R$ 670(com ou sem espaço)mil" & @CRLF & _
"Assim como eu sai de um faturamento de 10k para 300k" & @CRLF & _
"mentora que já faturei mais de R$ 670.000,00(com ou sem espaço)mil" & @CRLF & _
"Em 2022 R$1950 tudo isso por conta da mudança de posicionamento" & @CRLF & _
"Em um único dia minha mentoreanda faturou R$9.600" & @CRLF & _
"R$62.000 em 30 dias" & @CRLF & _
"R$62k em 30 dias" & @CRLF & _
"R$62 k em 30 dias" & @CRLF & _
"R$62mil em 30 dias" & @CRLF & _
"R$62 mil em 30 dias" & @CRLF & _
"R$5.014 foi o que a minha aluna faturou" & @CRLF & _
"R$12.000 de faturamento em menos de 15 dias de aplicação" & @CRLF & _
"faturou R$62.000 em 30 dias" & @CRLF & _
"faturei R$62k em 30 dias" & @CRLF & _
"faturamento de R$62 k em 30 dias" & @CRLF & _
"R$62mil em 30 dias" & @CRLF & _
"R$62 mil em 30 dias" & @CRLF & _
"R$5.014 foi o que a minha aluna faturou" & @CRLF & _
"R$12.000 de faturamento em menos de 15 dias de aplicação" & @CRLF & _
"Esse foi o resultado da @ utilizando o (meu) método" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"77k em 25 dias de aplicação" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(já\s|como\seu\ssai\sde\sum\s|em\sum\s[u|ú]nico\sdia\s(minha\smentoreanda\s|mentorada\s))*" & @CRLF & _
"Reais" & @CRLF & _
"(((R\$)+(\s)*(\d){1,6}(\s)*((\.|\,)*\d{1,3}|k|mil)*))+" & @CRLF & _
"parte decimal" & @CRLF & _
"((\.)(\d){1,3}|(\,)(\d){1,3})*" & @CRLF & _
"de tanto a tanto" & @CRLF & _
"(de(\d){1,3}\spara\s(\d){1,3})+" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"((((R\$)+(\s)*(\d){1,6}((\.)(\d){1,3}|(\,)(\d){1,3})*(\s)*(k|mil)*))+|(de(\d){1,3}\spara\s(\d){1,3})+)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")