package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Opuściwszy`)
var str = `Opuściwszy wieżę charakterników, powróciłem do domu. Sprawy organizacyjne związane z wydobyciem smoka z morskich otchłani zmierzały ku końcowi. Pozostała kwestia ponownego dogadania się z Gildią Kupiecką, a następnie zawarcia umowy z nimi oraz rzemieślnikami. Sprawy się klarowały, dobrze.
Miałem teraz odrobinę wolnego czasu. Postanowiłem wykorzystać tę chwilę na rozpoczęcie studiów potężnej księgi, w której spisano wiedzę na temat odnotowanych kultów w krainach ludzi. Cóż, zapewne mógłbym wykorzystać czas na odpoczynek, zajmując się czynnościami mało angażującymi, jednakże wolałem sobie posiedzieć przy zakazanej wiedzy i dowiedzieć się czegoś nowego.
Powolnym krokiem wszedłem po schodach, przekroczyłem próg mojej komnaty, usiadłem przy biurku wraz z księgą. Na początku zamierzałem zapoznać się z porządkiem treści. Po zakończeniu oględzin, zacząłem szukać jakiekolwiek informacji o ruinach świątyni w Myrwen, którą prawdopodobnie zbudowano ku czci Czerwonej Istoty. `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}