Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(www.|https?:\/\/(?:www.)?)?([a-z-_0-9]*)(?:\.)
/
gm
Input 1
1
New
www.xakep.ru https://swapi.co/api/planets/12/ //swapi http://github.com/carbonfive/raygun //github http://www.zombie-bites.com // https://www.cnet.com http://google.co.jp http://github.com/carbonfive/raygun https://www.cnet.com xewveqmwcz90sl64.co/ zx06u3ep-tcp8b25l.info j4yfack7z7pui8b8j-d3-abfdvp.it/img/ z8rabv26m.com