package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[embed type="(?:facebook|twitter|pinterest)"\](.*)\[\/embed\]`)
var str = `[embed type="pinterest"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]
[embed type="Twitter"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}