import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[embed type=\"(?:facebook|twitter|pinterest)\"\\](.*)\\[\\/embed\\]";
final String string = "[embed type=\"pinterest\"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]\n"
+ "[embed type=\"Twitter\"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}