const regex = /\[embed type="(?:facebook|twitter|pinterest)"\](.*)\[\/embed\]/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[embed type="(?:facebook|twitter|pinterest)"\\](.*)\\[\\\/embed\\]', 'ig')
const str = `[embed type="pinterest"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]
[embed type="Twitter"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}