re = /\[embed type="(?:facebook|twitter|pinterest)"\](.*)\[\/embed\]/i
str = '[embed type="pinterest"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]
[embed type="Twitter"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end