// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)\[embed type="(?:facebook|twitter|pinterest)"\](.*)\[\/embed\]"#).unwrap();
let string = "[embed type=\"pinterest\"]https://www.facebook.com/Techzoom.TV/posts/1960179340843049[/embed]
[embed type=\"Twitter\"]https://twitter.com/HelloBdWorld/status/1568289461284524033[/embed]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}