using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((non-)?(interactive|login) ?){2}";
string input = @"interactive login
non-interactive login
interactive non-login
non-interactive non-login";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}