package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((non-)?(interactive|login) ?){2}`)
var str = `interactive login
non-interactive login
interactive non-login
non-interactive non-login`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}