#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w,\s-]+\.(jpg|jpeg|png|gif|pdf)$"
Local $sString = "resource.png" & @CRLF & _
"resource.zip" & @CRLF & _
"resource.pdf" & @CRLF & _
"resource." & @CRLF & _
"resource.jpg" & @CRLF & _
"resource.jpeg" & @CRLF & _
".pdf" & @CRLF & _
"r$esource.pdf" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")