package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w,\s-]+\.(jpg|jpeg|png|gif|pdf)$`)
var str = `resource.png
resource.zip
resource.pdf
resource.
resource.jpg
resource.jpeg
.pdf
r$esource.pdf
// You can show origina post on albertcolom.com/blog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}