import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w,\\s-]+\\.(jpg|jpeg|png|gif|pdf)$";
final String string = "resource.png\n"
+ "resource.zip\n"
+ "resource.pdf\n"
+ "resource.\n"
+ "resource.jpg\n"
+ "resource.jpeg\n"
+ ".pdf\n"
+ "r$esource.pdf\n\n"
+ "// You can show origina post on albertcolom.com/blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}