// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w,\s-]+\.(jpg|jpeg|png|gif|pdf)$").unwrap();
let string = "resource.png
resource.zip
resource.pdf
resource.
resource.jpg
resource.jpeg
.pdf
r$esource.pdf
// You can show origina post on albertcolom.com/blog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}