const regex = /^([0-9]{4})(\s*|\/|[-]|[.])([0-1][0-9])(\s*|\/|[-]|[.])([0-9]{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{4})(\\s*|\\\/|[-]|[.])([0-1][0-9])(\\s*|\\\/|[-]|[.])([0-9]{2})$', 'gm')
const str = `January 14, 2018
2018/07/18
20180718
2018.07.18
2018-08-18
181007
20181202
201107
921109
13 กันยายน 2535
1ธันวาคม2561
1ธันวา2561
5 กันยา 61
1กันยา2501
1 September 2018
15October18
1/9/2018
10/3/2018
12/12/2018
4 กันยา 2018
12-12-18
12-9-2018
12Sep 2018
15มีนาคม 2018
15.Sep.2018`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}