using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A\d{7,8}00";
string input = @"ABC12345678CRP1234567F2801209A1234567800<<<33";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}