# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\[[^][]*)\s+(?=[^][]*])/_/gm;t' <<< "[ a b c ] d e f
[Skip a Payment] [decimal](18,2)"