#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\[[^][]*)\s+(?=[^][]*])"
Local $sString = "[ a b c ] d e f" & @CRLF & _
"[Skip a Payment] [decimal](18,2)"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)