import Foundation
let pattern = #"(?<=\[[^][]*)\s+(?=[^][]*])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[ a b c ] d e f
[Skip a Payment] [decimal](18,2)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)