using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:<([a-zA-Z]+)(?:[ \n]+[a-zA-Z]+(?:=([""'])[\-\/_a-zA-Z0-9 &;.:?=#]*(\3))?)*>(?1)?<\/(\2)>|[a-zA-Z0-9\-_\n &;.:?=#]+)+|<!--.*?-->)$";
string input = @"<a href=""https://codegolf.stackexchange.com/2?b=2"">abc<span title=""a""></span></a><b><!--abc<b>--></b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}