$re = '/(?:.*?\K20[1-2]{1}[2-9]{1}){2}/m';
$str = '0412023982012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);