using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0\.[1-9]|[1-9]\.?\d?)$";
string input = @"01
0.0
1,1
2.75
27.5
999
ab
0.0
Examples OK:
0.1
0.1
1
5.5
10
99";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}