import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d\\d\\d\\d-\\d\\d-\\d\\dT\\d\\d:\\d\\d:\\d\\d\\.\\d\\d\\d\\d\\d\\d-\\d\\d:\\d\\d) (.*?) (.*?): (.*)$";
final String string = "2021-02-17T13:55:32.924454-05:00 web50 systemd-logind[889]: New session 185577 of user mcmac.\n"
+ "2021-02-17T13:55:47.082860-05:00 wev37 sudo: pam_unix(sudo:session): session opened for user root by mcmac(uid=0)\n"
+ "2021-02-17T13:47:52.954190-05:00 apiproxy-test02 systemd: pam_unix(systemd-user:session): session opened for user nate by (uid=0)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}