use strict;
my $str = '2021-02-17T13:55:32.924454-05:00 web50 systemd-logind[889]: New session 185577 of user mcmac.
2021-02-17T13:55:47.082860-05:00 wev37 sudo: pam_unix(sudo:session): session opened for user root by mcmac(uid=0)
2021-02-17T13:47:52.954190-05:00 apiproxy-test02 systemd: pam_unix(systemd-user:session): session opened for user nate by (uid=0)';
my $regex = qr/^(\d\d\d\d-\d\d-\d\dT\d\d:\d\d:\d\d\.\d\d\d\d\d\d-\d\d:\d\d) (.*?) (.*?): (.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}