const regex = /^(?=[\D]*\d)(?=[^a-zA-Z]*[a-zA-Z])(?=.{6,})(?!.*(\d)\1{2})(?!.*([a-zA-Z])(?:.*?\2){2,}).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[\\D]*\\d)(?=[^a-zA-Z]*[a-zA-Z])(?=.{6,})(?!.*(\\d)\\1{2})(?!.*([a-zA-Z])(?:.*?\\2){2,}).*$', 'gm')
const str = `jj112233
jkhsfsndbf8uwwe
a1234
nsds312
111aaa222
aa1aa1aa1
hbsd12
aa11bbsd
hgshsadh12
hh8uqweuu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}